Background job delays impacting sync, webhook and email delivery

Incident Report for Doppler

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 11:46 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 10:54 PST

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 08:43 PST

Investigating

We are currently investigating an issue involving delays impacting integration sync, webhook and email delivery.
Posted Nov 20, 2025 - 07:55 PST
This incident affected: Integrations (Vercel, Heroku, AWS Parameter Store, AWS Secrets Manager, Azure App Service, Azure Key Vault, Azure Dev Ops, CircleCI, Codefresh, Fly.io, GCP Secret Manager, GitHub, Laravel Forge, Netlify, Railway, Render, Vercel, AWS IAM Dynamic Secrets, AWS MySQL Rotation, AWS User Key Rotation, SendGrid Rotation, Twilio Rotation, Splunk) and Dashboard (dashboard.doppler.com).